Jump to Navigation

119 - To install the PECL uploadprogress library

IThe report of drupal site says that the upload progress module gives you an error.

The error is the following:

"Upload progress Not trained Your server is capable of displaying file upload progress,
but does not have the required libraries.
It is recommended to install the PECL uploadprogress library (prefered) or to install APC."

You need to install the PHP developer package.

$ sudo apt-get install php5-dev

( CentOS, Redhat : $ yum install php-pear )

Then, install the PECL uploadprogress library:
$ sudo pecl install uploadprogress

Edit php.ini :
$ sudo vi /etc/php5/apache2/php.ini
Add the line "extension=uploadprogress.so" to php.ini

Restart apache:
$ sudo /etc/init.d/apache2 restart

drupal:


Main menu 2

Story | by Dr. Radut